(1.7.10) Cauldron, Forge Worldedit - Commands do not work.

Discussion in 'Server Help' started by SabbyKat, Jan 15, 2016.

  1. SabbyKat

    SabbyKat New Member

    Alright! I'm at my wits end for this issue. If I use the BUKKIT version of worldedit, everything is jiffy except for one major flaw - the inability to add modded metadata (//replace 102 712:21) to commands. I could not find any info to solve this, bar 'use forge! Duh!'.

    I've added forge worldedit (removing bukkit worldedit, its configs, all that properly) to have it basically state unknown command, use /help for info - but it (the error message) shows in red, not white like a real missing command.

    It works just fine on single player with identical installs, but not multiplayer.

    Yes, I've tried to disable the config for '//' - it does absolutely nothing.

    I've uninstalled ALL plugins and ALL mods on a fresh world, with JUST forge worldedit, to have the same issue (as an /op'd individual of course). So I can confirm mods/plugins are not conflicting with it.

    There is no error i can find in the fml logs, crash logs, or console logs. It simply does not work. I am entirely at my wits end to the cause, and hoping someone here, has some insight!

    Any further info needed, just ask.

    Exact info:

    Worldedit version: 6.0 - Forge

    Cauldron Version: KCauldron-1.7.10-1614.174
  2. wizjany

    wizjany Administrator Developer

    712:21 isn't a valid block.
    block metadata will never be above 15. you are either looking at item metadata or nbt data.

    make sure you're using the 1.7.10 version of worldedit, as there are 6.x build that also are made for 1.8+

    aside from that, kcauldron is known to be rather buggy, and we offer no support for it specifically.
  3. SabbyKat

    SabbyKat New Member

    712 is a valid block in my install, and used as a random example for meta data I pulled out of my rear :) But yes, the point for that is trying to use any mod block+meta data for a block in replace, or any function does not work with the bukkit version (and I tested various 1.7.10 compatible ones to ensure it wasn't just the version being picky).

    as clarified, 6.0 is 1.7.10 - 6.1 is 1.8+ (for the forge branch, in bukkit 1.6.1 is the 1.7.10 branch oddly). I did even try to put the 1.8 forge version in just to see if it changed anything - it would not even load.

    Kcauldron is the only feasible option to run a server without losing options to various major plugins that Forge has not implemented at all, or at an equal level to date. So I would hope by now, modders would have embraced it at least somewhat.

    So basically 'too bad, so bad, we dunno whats wrong'. Hopefully, someone else has experienced this issue and has some idea. *sigh*
  4. wizjany

    wizjany Administrator Developer

    the bukkit version is almost guaranteed not to work since kcauldron makes no attempts at being compatible with craftbukkit-specific code afaik. the forge mod should in theory work as it doesn't do anything funny. however, you haven't really provided enough info for any conclusions to be made, would be more useful if you could post your logs.
  5. PseudoKnight

    PseudoKnight Well-Known Member

    Just to clarify, he wasn't talking about 712. He was talking about 21.
  6. InuYasha86000

    InuYasha86000 New Member

    From one section in your title message i'm seeing, this is gonna sound stupid, but are you OPed AND have PERMISSION to use worldedit on the Kcauldron server? I ask this as I am running the same version as you with forge version (client side) and plugin version (server side) and they work on my modpacks blocks no problem.
    the red USUALLY means you don't have permission on a server to use that command, this is what i'm going off of. if i'm wrong, at least I tried with a possible fix.