Bans Aren't Working

Discussion in 'CommandBook' started by Murreey, Nov 6, 2014.

  1. Murreey

    Murreey Member

    Hi,

    For some reason bans on my server using CommandBook aren't staying anymore. We ban the person, and they can immediately log back in.

    The bans.0.0.log file doesn't show them as ever being banned, but when you do /unban it does show the "Player unbanned" message. I know it's not a case of somehow accidentally using vanilla bans or something, as it works the same when I do /commandbook:ban. Not sure if it's related, but our bans.0.0.log file did just pass 25,000 lines in case that's got something to do with it.

    Thanks!
  2. Murreey

    Murreey Member

    I hate to bump, but this is pretty urgent. It turns it also anyone who was previously banned can login, so it's causing us some obvious issues. Any help would be appreciated!

    Otherwise I guess I'll just have to find another ban manager asap.
  3. PseudoKnight

    PseudoKnight Well-Known Member

    Bans were switched to UUIDs, so I imagine that might be related. What version are you using? Does your ban list still exist? Did you change anything in the config? Do any errors occur in the startup log or when bans are mad

    You should be able to rename the log if you want it to create a new one. It's just to keep track of ban history, not store the actual bans.
  4. Murreey

    Murreey Member

    Renaming the log apparently fixed it. It turns out the bans.csv was still updating with correct UUIDs etc, but the log wasn't. I just changed one of the numbers in the log files name and it's now working perfectly.

    I've no idea what happened, but thanks for your help!