Commandbook config overwriting [Resolved]

Discussion in 'CommandBook' started by Bobthehalfdead, Oct 5, 2014.

  1. Bobthehalfdead

    Bobthehalfdead New Member

    Before I complain, I just want to thank SK and company for all the great plugins. Server administration wouldn't be the same without you! :)

    Now to the issue:
    When I try to edit the commandbook config (with the server stopped) as soon as I start the server it is immediately overwritten with the stock configuration.

    I have attempted to search for the cause, but I just can't seem to find any information on why this would keep happening. Any info would be appreciated!
  2. PseudoKnight

    PseudoKnight Well-Known Member

    It may be resetting the config because of an error in the syntax. Make sure you're following yaml syntax. (no tabs, exact space indentation, etc) If you're unsure, paste it in a yaml tester or here. If you're still having problems, make changes one by one.
  3. Bobthehalfdead

    Bobthehalfdead New Member

    Hey PseudoKnight,

    Thanks for taking a look at this, here is a pastebin of my updated config. All I am trying to do is comment out the MOTD and Rules section of the config:
    http://pastebin.com/g96Nm353

    YAML parser doesn't give me any errors.
  4. PseudoKnight

    PseudoKnight Well-Known Member

    You shouldn't comment this out because it'll just generate it again if it's missing. You should just disable the stored-messages component. If you still want blank motd, you should specify empty quotes.

    Code (Text):
        stored-messages:
           motd: ''
           rules: ''
  5. Bobthehalfdead

    Bobthehalfdead New Member

    That got it, right there, thanks for the help.