error

Discussion in 'WorldGuard' started by ProDash, Aug 5, 2017.

  1. ProDash

    ProDash New Member

    Code (Text):
    [13:53:58 ERROR]: Could not load 'plugins\worldguard-6.2.1.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandsManager
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[hub1.jar:git-Paper-1172]
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328) ~[hub1.jar:git-Paper-1172]
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [hub1.jar:git-Paper-1172]
            at org.bukkit.craftbukkit.v1_12_R1.CraftServer.loadPlugins(CraftServer.java:299) [hub1.jar:git-Paper-1172]
            at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:223) [hub1.jar:git-Paper-1172]
            at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:616) [hub1.jar:git-Paper-1172]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_131]
    Caused by: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandsManager
            at java.lang.Class.forName0(Native Method) ~[?:1.8.0_131]
            at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_131]
            at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:65) ~[hub1.jar:git-Paper-1172]
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[hub1.jar:git-Paper-1172]
            ... 6 more
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.CommandsManager
            at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_131]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:102) ~[hub1.jar:git-Paper-1172]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:87) ~[hub1.jar:git-Paper-1172]
            at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_131]
            at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_131]
            at java.lang.Class.forName0(Native Method) ~[?:1.8.0_131]
            at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_131]
            at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:65) ~[hub1.jar:git-Paper-1172]
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[hub1.jar:git-Paper-1172]
            ... 6 more
    Server version 1.12.1 because no 1.12? Because he wants to be on the latest version
  2. wizjany

    wizjany Administrator Developer

    read the install instructions