HELP: WorldGuard 1.7.10 - ANY server

Discussion in 'WorldGuard' started by Bradley Brand, Dec 3, 2017.

  1. Bradley Brand

    Bradley Brand New Member

    Dear everyone,

    I am trying to create a Minecraft server which supports WorldGuard. I tried making a clean Thermos server and added both the WorldEdit and WorldGuard plugins into the Plugin folder - WorldEdit seemed to work, but nothing WorldGuard worked.

    I noticed on the download page of WorldGuard, I couldn't narrow it down to 1.7.10 - which is a good version which many mods seem to support.

    In past, I tried a Forge server with ForgeEssentials but still could not get WorldGuard to work.

    I tried the _region define NAME command and it doesn't work. ForgeEssentials on Forge only allowed me to make a area, not a region - did not allow ANY region flags either.

    Please help me out. Cannot understand why I cannot get it to work at all. Would love to create regions on my Server with flags and ownership. Any other mods you would suggest to go with these two?

    Brad.
  2. Bradley Brand

    Bradley Brand New Member

    It's obvious WorldGuard is the issue...

    Does anyone know a WorldGuard version I can use, compatible with 1.7.10? There doesn't seem to be one. Does anyone know of any other version which is compatible?

    If not, what version and version of Server would you guys recommend?

    Code (Text):
    [00:05:49 INFO]: [WorldGuard] Enabling WorldGuard v6.2.1;84bc322
    [00:05:49 ERROR]: Error occurred while enabling WorldGuard v6.2.1;84bc322 (Is it up to date?)
    java.lang.NoSuchMethodError: guava10.com.google.common.cache.CacheBuilder.maximumSize(J)Lguava10/com/google/common/cache/CacheBuilder;
            at com.sk89q.worldguard.session.SessionManager.<init>(SessionManager.java:60) ~[?:?]
            at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:170) ~[?:?]
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:316) ~[JavaPlugin.class:1.7.10-1614.57]
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:368) [JavaPluginLoader.class:1.7.10-1614.57]
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:410) [SimplePluginManager.class:1.7.10-1614.57]
            at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugin(CraftServer.java:438) [CraftServer.class:1.7.10-1614.57]
            at org.bukkit.craftbukkit.v1_7_R4.CraftServer.enablePlugins(CraftServer.java:372) [CraftServer.class:1.7.10-1614.57]
            at net.minecraft.server.MinecraftServer.func_71243_i(MinecraftServer.java:519) [MinecraftServer.class:?]
            at net.minecraft.server.MinecraftServer.func_71222_d(MinecraftServer.java:493) [MinecraftServer.class:?]
            at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:453) [MinecraftServer.class:?]
            at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:337) [lt.class:?]
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:643) [MinecraftServer.class:?]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_151]
  3. PseudoKnight

    PseudoKnight Well-Known Member Developer

    6.2.1 is not compatible with 1.7.10, as mentioned in the release notes. Use anything earlier than that. I'm not sure if 6.2 will fully work (and there's definitely certain features that won't work with all mods, as this is a Bukkit plugin), but 6.2.1 is definitely the wrong version.

    [edit] You may have tried earlier versions already, but the only stacktrace you posted was for 6.2.1.