No building allowed?

Discussion in 'WorldGuard' started by uniquename, Aug 17, 2011.

  1. uniquename

    uniquename New Member

    I have WorldEdit and WorldGuard plugins running on my new bukkit server, however whenever a user that is not an OP attempts to build anything, in any region, it is not allowed, basically they only have observing rights.

    I have only installed this plugin today, and everything works except for this.

    I've tried to allow build in the local AND global regions that exist, using /region flag __global__ build allow and /region flag <regionname> build allow. This still isnt working, therefore i deduced it must be something to do with permissions, but the problem is theres next to no real help with permissions on the wiki, just a list. I dont even know if i have the proper file or not. In the root folder of the bukkit server, there is a permissions.yml file that has nothing written in it, in each of WorldGuard and WorldEdit theres a configuration folder that doesnt have any "build" related things in it, and in each "world" subfolder of the WorldGuard folder has a configuration.yml that is empty and a regions.yml that just shows the regions (including the ones that have the build:allow flag in them).

    Is Permissions some other plugin I need? Or is the empty permissions.yml the problem? (in the bukkit.yml this is shown [permissions-file: permissions.yml], so the permissions folder is properly referenced)

    Thanks for your time,

    Here's the pasted contents of each file:

    ../(root server folder)/permissions.yml
    <it was empty to begin with>

    ---------------------------------------------------------

    ../(root server folder)/plugins/WorldGuard/config.yml
    Code (Text):
    #
    # WorldGuard's main configuration file
    #
    # This is the global configuration file. Anything placed into here will
    # be applied to all worlds. However, each world has its own configuration
    # file to allow you to replace any setting in here for that world only.
    #
    # About editing this file:
    # - DO NOT USE TABS. You MUST use spaces or Bukkit will complain. If
    #   you use an editor like Notepad++ (recommended for Windows users), you
    #   must configure it to "replace tabs with spaces." In Notepad++, this can
    #   be changed in Settings > Preferences > Language Menu.
    # - Don't get rid of the indents. They are indented so some entries are
    #   in categories (like "enforce-single-session" is in the "protection"
    #   category.
    # - If you want to check the format of this file before putting it
    #   into WorldGuard, paste it into http://yaml-online-parser.appspot.com/
    #   and see if it gives "ERROR:".
    # - Lines starting with # are comments and so they are ignored.
    #

    iconomy:
        buy-on-claim-price: 1.0
        enable: false
        buy-on-claim: false
    buy-on-claim-price: 1.0
    enable: false
    buy-on-claim: false
    protection:
        enforce-single-session: true
        item-durability: true
        remove-infinite-stacks: false
    enforce-single-session: true
    item-durability: true
    remove-infinite-stacks: false
    chest-protection:
        enable: false
    physics:
        allow-portal-anywhere: false
        no-physics-sand: false
        no-physics-gravel: false
        disable-water-damage-blocks: []
    allow-portal-anywhere: false
    no-physics-sand: false
    no-physics-gravel: false
    disable-water-damage-blocks: []
    ignition:
        block-tnt: false
        block-lighter: false
    block-tnt: false
    block-lighter: false
    regions:
        max-region-count-per-player: 7
        claim-only-inside-existing-regions: false
        max-claim-volume: 30000
        high-frequency-flags: false
        enable: true
        use-scheduler: true
        wand: 287
    build: allow
    max-region-count-per-player: 24
    claim-only-inside-existing-regions: false
    max-claim-volume: 30000
    high-frequency-flags: false
    use-scheduler: true
    wand: 287
    simulation:
        sponge:
            redstone: false
            enable: true
            radius: 3
        classic-water: false
    sponge:
    redstone: false
    radius: 3
    classic-water: false
    fire:
        disable-lava-fire-spread: true
        lava-spread-blocks: []
        disable-fire-spread-blocks: []
        disable-all-fire-spread: false
    disable-lava-fire-spread: true
    lava-spread-blocks: []
    disable-fire-spread-blocks: []
    disable-all-fire-spread: false
    suppress-tick-sync-warnings: false
    spawn:
        login-protection: 3
        exact-respawn: false
        teleport-to-home-on-death: false
        kick-on-death: false
        spawn-protection: 0
    login-protection: 3
    exact-respawn: true
    teleport-to-home-on-death: false
    kick-on-death: false
    spawn-protection: 0
    default:
        disable-health-regain: false
    disable-health-regain: false
    mobs:
        anti-wolf-dumbness: false
        block-creature-spawn: []
        block-creeper-block-damage: false
        block-creeper-explosions: false
    anti-wolf-dumbness: false
    block-creature-spawn: []
    block-creeper-block-damage: true
    block-creeper-explosions: false
    dynamics:
        disable-ice-melting: false
        disable-snow-formation: false
        disable-mushroom-spread: false
        disable-snow-melting: false
        disable-leaf-decay: false
        disable-ice-formation: false
    disable-ice-melting: false
    disable-snow-formation: false
    disable-mushroom-spread: false
    disable-snow-melting: false
    disable-leaf-decay: false
    disable-ice-formation: false
    blacklist:
        use-as-whitelist: false
        logging:
            console:
                enable: true
            file:
                path: worldguard/logs/%Y-%m-%d.log
                enable: false
                open-files: 10
            database:
                dsn: jdbc:mysql://localhost:3306/minecraft
                enable: false
                table: blacklist_events
                user: root
                pass: ''
    use-as-whitelist: false
    logging:
    console:
    file:
    path: worldguard/logs/%Y-%m-%d.log
    open-files: 10
    database:
    dsn: jdbc:mysql://localhost:3306/minecraft
    table: blacklist_events
    user: root
    pass: ''
    summary-on-start: true
    weather:
        always-raining: false
        disable-powered-creepers: false
        disable-weather: false
        disable-lightning-strike-fire: false
        always-thundering: false
        prevent-lightning-strike-blocks: []
        disable-thunderstorm: false
        disable-pig-zombification: false
    always-raining: false
    disable-powered-creepers: false
    disable-weather: true
    disable-lightning-strike-fire: false
    always-thundering: false
    prevent-lightning-strike-blocks: []
    disable-thunderstorm: false
    disable-pig-zombification: false
    crops:
        disable-creature-trampling: false
        disable-player-trampling: false
    disable-creature-trampling: false
    disable-player-trampling: false
    op-permissions: true
    player-damage:
        teleport-on-void-falling: false
        disable-drowning-damage: false
        disable-mob-damage: false
        disable-explosion-damage: false
        disable-void-damage: false
        disable-fall-damage: false
        disable-fire-damage: false
        disable-contact-damage: false
        disable-suffocation-damage: false
        disable-lightning-damage: false
        disable-lava-damage: false
        teleport-on-suffocation: false
    teleport-on-void-falling: true
    disable-drowning-damage: false
    disable-mob-damage: false
    disable-explosion-damage: false
    disable-void-damage: true
    disable-fall-damage: false
    disable-fire-damage: false
    disable-contact-damage: false
    disable-suffocation-damage: false
    disable-lightning-damage: false
    disable-lava-damage: false
    teleport-on-suffocation: false
    pumpkin-scuba: true
    auto-invincible-permission: false
     
    ---------------------------------------------------------------------------

    ../(root server folder)/plugins/WorldGuard/worlds/<worldname>/config.yml

    Code (Text):
    #
    # WorldGuard's world configuration file
    #
    # This is a world configuration file. Anything placed into here will only
    # affect this world. If you don't put anything in this file, then the
    # settings will be inherited from the main configuration file.
    #
    # If you see {} below, that means that there are NO entries in this file.
    # Remove the {} and add your own entries.
    #

    {}
    ----------------------------------------------------------------------------

    ../(root server folder)/plugins/WorldGuard/worlds/<worldname>/regions.yml

    Code (Text):
    #
    # WorldGuard regions file
    #
    # WARNING: THIS FILE IS AUTOMATICALLY GENERATED. If you modify this file by
    # hand, be aware that A SINGLE MISTYPED CHARACTER CAN CORRUPT THE FILE. If
    # WorldGuard is unable to parse the file, your regions will FAIL TO LOAD and
    # the contents of this file will reset. Please use a YAML validator such as
    # http://yaml-online-parser.appspot.com (for smaller files).
    #
    # REMEMBER TO KEEP PERIODICAL BACKUPS.
    #
    regions:
      castleterminal:
        min: {z: -138.0, y: 0.0, x: -77.0}
        flags: {}
        max: {z: -129.0, y: 127.0, x: -57.0}
        priority: 0
        type: cuboid
        owners:
          players: [uniquename]
        members: {}
      villagetrainstation:
        min: {z: -156.0, y: 63.0, x: -6.0}
        flags: {build: allow, use:allow}
        max: {z: -153.0, y: 65.0, x: -3.0}
        priority: 0
        type: cuboid
        owners:
          players: [uniquename]
        members: {}
      village:
        min: {z: -159.0, y: 0.0, x: -2.0}
        flags: {}
        max: {z: -92.0, y: 127.0, x: 34.0}
        priority: 0
        type: cuboid
        owners:
          players: [kyle_krishnappa]
        members: {}
      __global__:
        flags: {use: allow, build: allow}
        priority: 0
        type: global
        owners: {}
        members: {}
      castle:
        min: {z: -176.0, y: 0.0, x: -89.0}
        flags: {}
        max: {z: -143.0, y: 127.0, x: -64.0}
        priority: 0
        type: cuboid
        owners:
          players: [uniquename]
        members: {}
      villagetunnels:
        min: {z: -165.0, y: 0.0, x: -58.0}
        flags: {}
        max: {z: -116.0, y: 127.0, x: -3.0}
        priority: 0
        type: cuboid
        owners:
          players: [uniquename]
        members: {}
      villagetunnelstation:
        min: {z: -138.0, y: 64.0, x: 8.0}
        flags: {build: allow, use:allow}
        max: {z: -137.0, y: 64.0, x: 8.0}
        priority: 0
        type: cuboid
        owners:
          players: [kyle_krishnappa]
        members: {}
     
  2. uniquename

    uniquename New Member

    On further investigation, I have found and installed the Permissions plugin, however noone is allowed to build still; here is the users.yml for the world im using:
    Code (Text):
    users:
        Uniquename:
            groups:
            - Admins
            permissions:
            - '*':   -'*'

        jtapper:
            groups:
            - Builder
            permissions:
        kyle_krishnappa:
            groups:
            - Moderator
            permissions:
            - worldedit.*
            - worldguard.*
    and the groups.yml:

    Code (Text):
    groups:
        Default:
            default: true
            info:
                prefix: '&2'
                suffix: '&f'
                build: false
            permissions:

        Builder:
            default: false
            info:
                prefix: '&2'
                suffix: '&f'
                build: true
            inheritance:
                - Default
            permissions:


        Moderator:
            default: false
            info:
                prefix: '&b'
                suffix: '&f'
                build: true
            inheritance:
                - Default
            permissions:
                - 'worldedit.*'
                - 'worldguard.*'
        Admins:
            default: false
            info:
                prefix: '&4'
                suffix: '&f'
                build: true
            permissions:
                - '*':
                - '*'
    -------------------------------------------

    The global's are left blank (globalUsers.yml, globalGroups.yml), as I'm only running one world at the moment and it's probably best if I only configure this world at the moment.

    After installing permissions, everything worked the same as it did before, when it wasn't installed. Not sure where to go from here, whether it's a syntax error in my permissions or I'm missing a permission file or something.

    Hope this adds more clues to what is wrong. Thanks
  3. wizjany

    wizjany Administrator Developer

    does it actually give a message that they're not allowed to build?
    worldguard will always send the player a message if it denies an action, except the blacklist which only does so if you specify tell
    any other plugins you have? any errors in console?
  4. uniquename

    uniquename New Member

    No, I've tested this with friends and with my own account, de-opping myself. If a user tries to build in a region they are not the owner of, it gives the "cannot build here" message, however when any non-op user (jtapper) attempts to dig or build anywhere else(even in non-regions) the block is placed there for a split second then dissappears. There's no message from any plugin to the users in-game.

    Thing is, before I installed Permissions(which was when I made the first post) it was doing the exact same thing as after I installed it (at which point I added the second post), any user was finding blocks they placed anywhere (even outside regions) quickly dissappeared. This only occured after WorldEdit/Worldguard was installed.

    The plugins im running are(in order of installation):
    -dynmap:
    -WorldEdit
    -WorldGuard
    -Permissions

    There is a few error messages in the console, and it occurs when parsing the users.yml in ../plugins/Permissions/world/users.yml (the world specific file).

    Code (Text):
    11:28:46 [SEVERE] while parsing a block mapping
    in "<reader>", line 2, column 5:
        uniquename:
        ^
    expected <block end>, but found BlockSequenceStart
     in "<reader>", line 16, column 8:
        - worldedit.*
        ^

    //bunch of severe errors relating to permissions due to the failed parsing//

    11:28:46 [SEVERE] [Permissions] Unable to load permission data.
    11:28:46 [SEVERE] [Permissions] Shutting down Permissions due to error<s>.
    11:28:46 [SEVERE] [Permissions] <Yeti> was initialized.
    11:28:46 [SEVERE] [Permissions] <Yeti> disabled successfully.
     
    //then on to preparing the world etc, also WorldEdit enables and this shows as it happens "No known permissions plugin detected. Using configuration file for permissions." Same message for WorldGuard as it enables.//

    I've tried looking for ways to correct the apparently broken syntax but there's not much information on the Permissions wiki regarding my specific syntax problem; I essentially copied the provided code example on the wiki and changed privileges and user names accordingly. Not sure why they are throwing up those error messages basically.

    I hope all this helps, I'm considering disabling dynmap to see if that fixes the issue. Will post again with results. Thanks again.
  5. uniquename

    uniquename New Member

    After disabling dynmap the same error messages occur and nothing changes, dynmap appears not to affect the situation.
  6. wizjany

    wizjany Administrator Developer

    it's a permissions plugin problem
    you screwed up your yml so it's denying build for someone
    also like i said, if it doesn't give the can't build message, it's not worldguard

    i suggest your fix your permissions yml files or recreate them
    the error messages should give you an idea of where the problems are, if not what as well
  7. uniquename

    uniquename New Member

    Ok, thanks for your help, I'll retry the permissions files and hope for the best.
  8. Xzombiehunter7X

    Xzombiehunter7X New Member

    I have the same problem, no error message, but cant build. I followed your instructions but nothing. I redownloaded my perms plugin but that didnt change anything...
    But whatever, I NEED HELP URGENTLY or else my server cant go public D:
  9. PseudoKnight

    PseudoKnight Well-Known Member Developer

    "if it doesn't give the can't build message, it's not worldguard"

    Check your other plugins and configuration settings.
  10. Xzombiehunter7X

    Xzombiehunter7X New Member

    Ok, thanks it turns out it was Spout effing it all up xD I dont even know how D: