Rhino 1.7R2 unreadable/not valid zip file when building with maven

Discussion in 'Programming Help' started by Hexeddude, Oct 31, 2016.

  1. Hexeddude

    Hexeddude New Member

    My pom: http://pastebin.com/RJiv8ixt

    My Error:
    "Archive for required library: '/Users/*insert jewish sounding name here*/.m2/repository/rhino/js/1.7R2/js-1.7R2.jar' in project 'CeruleanProsopidicola' cannot be read or is not a valid ZIP file"

    When I was initially given this error my first thought was to just pull the corresponding version from adobe's repository but that didn't have any effect. Obviously I'm doing something wrong and I've been scratching my head as to what gives.
  2. wizjany

    wizjany Administrator Developer

    your cached version must be invalid? try just deleting that from your local repo (at the path provided)
    i've never used rhino as a dependency via a build tool, so we don't actually have it on our repo. unsure about the adobe one.
    Hexeddude likes this.
  3. Hexeddude

    Hexeddude New Member

    Thank you kindly sir