[Sever errors]

Discussion in 'WorldGuard' started by Grayles, Apr 25, 2012.

  1. Grayles

    Grayles New Member

    Code (Text):
    2012-04-25 20:54:22 [SEVERE] You need to update your database to the latest version.
            Please see region_storage_update_20110325.sql
    2012-04-25 20:54:22 [SEVERE]     at com.sk89q.worldguard.protection.databases.MySQLDatabase.<init>(MySQLDatabase.java:81)
    2012-04-25 20:54:22 [SEVERE]     at com.sk89q.worldguard.protection.GlobalRegionManager.load(GlobalRegionManager.java:147)
    2012-04-25 20:54:22 [SEVERE]     at com.sk89q.worldguard.protection.GlobalRegionManager.preload(GlobalRegionManager.java:186)
    2012-04-25 20:54:22 [SEVERE]     at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:140)
    2012-04-25 20:54:22 [SEVERE]     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:215)
    2012-04-25 20:54:22 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:336)
    2012-04-25 20:54:22 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    2012-04-25 20:54:22 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:250)
    2012-04-25 20:54:22 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:232)
    2012-04-25 20:54:22 [SEVERE]     at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:371)
    2012-04-25 20:54:22 [SEVERE]     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:358)
    2012-04-25 20:54:22 [SEVERE]     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:187)
    2012-04-25 20:54:22 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:422)
    2012-04-25 20:54:22 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    This is the error i receive. Can anyone tell me what im doing wrong? I have the schema correct and stuff and im sure i filled it up properly. Also i reinstalled to the latest mysql and workbench

    Code (Text):
        sql:
            use: true
            dsn: jdbc:mysql://localhost/worldguard
  2. zXTechnoWolf

    zXTechnoWolf New Member

    I got the same error, and can't figure it out. If you find out the solution, please tell me.