Spigot 1.13.1 Error

Discussion in 'WorldGuard' started by DeepBlue75, Sep 17, 2018.

  1. DeepBlue75

    DeepBlue75 New Member

    hello
    first of all thx for the great plugins ;-) and hello everyone!

    As i am arrived here, i got a problem.
    I hope someone can help me.

    Only active plugin is Vault

    Thx
    DB

    [19:06:07 INFO]: Set PluginClassLoader as parallel capable
    [19:06:07 ERROR]: Could not load 'plugins/worldguard-legacy-7.0.0-SNAPSHOT-dist.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandPermissionsException
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:327) ~[spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:248) [spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    at org.bukkit.craftbukkit.v1_13_R2.CraftServer.loadPlugins(CraftServer.java:317) [spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    at net.minecraft.server.v1_13_R2.DedicatedServer.init(DedicatedServer.java:213) [spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:702) [spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_181]
    Caused by: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandPermissionsException
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_181]
    at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_181]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:78) ~[spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    ... 6 more
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.CommandPermissionsException
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381) ~[?:1.8.0_181]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:154) ~[spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:100) ~[spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_181]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_181]
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_181]
    at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_181]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:78) ~[spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.13.1.jar:git-Spigot-6b015b4-a4bdecf]
    ... 6 more
    [19:06:07 INFO]: [Vault] Loading Vault v1.7.1-b91
    [19:06:07 INFO]: [Vault] Enabling Vault v1.7.1-b91
    [19:06:07 INFO]: [Vault] [Permission] SuperPermissions loaded as backup permission system.
    [19:06:07 INFO]: [Vault] Enabled Version 1.7.1-b91
  2. DeepBlue75

    DeepBlue75 New Member

    Little update:
    craftbukkit-1.13.1.jar seems to work
    spigot-1.13.1.jar doesnt
  3. PseudoKnight

    PseudoKnight Well-Known Member Developer

    If true, you need to also load WorldEdit. Make sure you're using the latest builds from the master branches.

    http://builds.enginehub.org/