Updating to 1.9?

Discussion in 'CommandBook' started by spartagon123, Mar 3, 2016.

  1. spartagon123

    spartagon123 New Member

    Are there plans to update this plugin to 1.9? I’ve looked around and it seems like theres been very little activity with this plugin for quite some time. Most of the other plugins on this forum have already been updated to 1.9, and I haven’t seen any indication for plans to update this one.
  2. wizjany

    wizjany Administrator Developer

    Not really. Whatever still works, works. Whatever doesn't, doesn't.
    Things like block/item names of the new 1.9 stuff for /give, etc are actually pulled from WorldEdit and will automagically work once we (manually) update the block database. Everything else should work as it did in 1.8.
  3. spartagon123

    spartagon123 New Member

    Oh really? It seems we’ve been having quite a few issues. Haven’t figured it out exactly, but most commands that interact with other players are broken. But what you’re saying seems to indicate that is a problem with something other than command book?
  4. wizjany

    wizjany Administrator Developer

    commandbook was never fully updated for 1.8 either, so it is almost entirely UUID unaware. I know that makes things like /home not work for users who have changed their username, for example, but nothing else has changed that I'm aware of.
  5. JDarksword

    JDarksword New Member

    I personally have noticed that in 1.9 /motd /warps list /tp and /rules give an error which is written in the console, I have only tested these few and none of the other commands featured.
  6. PseudoKnight

    PseudoKnight Well-Known Member

    What is the error?
  7. Schneidertm

    Schneidertm New Member

    If you are using the latest version form dev.bukkit.org there are errors caused by the org.bukkit.Server.getOnlinePlayers() that changed form a Array to an Collection due Spigot 1.9. But If just someone like wizjany could recompile the latest github code and upload it on dev.bukkit.org all these people would be happy. Because just a recompile fix all these org.bukkit.Server.getOnlinePlayers() issues.
  8. wizjany

    wizjany Administrator Developer

    yes, and the builds have already been on builds.enginehub.org for a year already. we dont want to release a full build on dbo that doesnt fully support the current versions of minecraft. people who want to continue using the plugin regardless should be able to get it from the dev build site.
  9. dats_me

    dats_me New Member

    Ok I think I am blind but in the afk command description it states "if configured to do so this will also make you invulnerable." However, I cannot find anything in the configuration file to set this option to true so when players type /afk, /away, or /afk away it makes them invulnerable. The permission for commandbook.away works and players can type the command but skeletons still shoot them and they take damage as usual.
    Is this just outdated and as wizjany says just doesn't work for the newer versions?
  10. wizjany

    wizjany Administrator Developer

    you need to turn on afk-command-protection.
    by default it only makes you invulnerable if you actually go afk for x amount of time to prevent /afk from being exploited like a /god command. (which is the afk-general-protection setting)
    also please don't bump old threads.
  11. dats_me

    dats_me New Member

    Thank you works perfect players are no longer taking damage when afk :)