WorldGuard No starting

Discussion in 'WorldGuard' started by ITechnologyman, Dec 7, 2017.

  1. ITechnologyman

    ITechnologyman New Member

  2. wizjany

    wizjany Administrator Developer

    pastebin your entire server log
  3. ITechnologyman

    ITechnologyman New Member

  4. ITechnologyman

    ITechnologyman New Member

    And for more information it did work but now it has stopped, some time in the past week.
  5. wizjany

    wizjany Administrator Developer

    read the release notes
  6. ITechnologyman

    ITechnologyman New Member

    Dumb question but where do i find these
  7. wizjany

    wizjany Administrator Developer

    on the download page
  8. ITechnologyman

    ITechnologyman New Member

    That does not help with why it does not start up
  9. ITechnologyman

    ITechnologyman New Member

    Just realised i made a typo, i meant version 6.1
  10. wizjany

    wizjany Administrator Developer

    in that case, read the installation instructions
  11. ITechnologyman

    ITechnologyman New Member

    I have, install word edit then world guard, still does not run.
  12. wizjany

    wizjany Administrator Developer

    the server is trying to load worldguard before it loads worldedit.
    this is a really really old bug with spigot and it's a bit ridiculous that they haven't fixed it.
    you can try renaming the worldedit jar file so it's first alphabetically, i have heard that work for some people in the past. but it's really just an issue with the server.
  13. ITechnologyman

    ITechnologyman New Member

    I get this error my support staff showed me it
    10/12/2017 5:03 PM: [MC]: [17:03:14 ERROR]: Could not load 'pluginsworldguard-6.1.jar' in folder 'plugins'
    10/12/2017 5:03 PM: [MC]: org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandsManager
  14. wizjany

    wizjany Administrator Developer

    same thing. you need worldedit to load before worldguard, not the other way around